Come eliminare risultato #DIV/0! da una funzione Excel

Come abbiamo già visto all’interno del post Il cerca.vert restituisce #N/D, come posso toglierlo? la funzione VAL.ERRORE può essere utilizzata anche in altri casi non soltanto se il problema si presenta con la funzione CERCA.VERT e non soltanto se l’errore che restituisce excel è #N/D. Può infatti capitare che venga applicata una funzione che fa la divisione tra 2 celle. A questo punto, se il divisore è pari a 0 la funzione restituirà un errore, precisamente #DIV/0! poichè non riesce a dividere per 0. Se si vuole togliere il risultato #DIV/0! allora basterà applicare la funzione VAL.ERRORE prima della divisione come nel seguente esempio:
A       B
1   10     100
2   5       100
3   0       100

=B1/A1   -> risultato 10

=B2/A2   -> risultato 20
=B3/A3   -> risultato #DIV/0


alternativa

=se(val.errore(B1/A1);”attenzione”, B1/A1)  -> risultato 10
=se(val.errore(B2/A2);”attenzione”, B2/A2)  -> risultato 20
=se(val.errore(B3/A3);”attenzione”, B3/A3)  -> risultato attenzione

Buon lavoro!


Excel If

Mentre alcuni utenti lavoreranno con la versione di Excel in italiano, altri staranno lavorando con la versione in inglese, a questo proposito, per tutti gli utenti che stanno cercando in formazioni sulla funzione Excel IF, vi rimando al post SE EXCEL in cui potrete trovare tutte le informazioni su come poter utilizzare la funzione IF (in inglese) oppure SE (per chi utilizza Excel in italiano).
Buon lavoro!

Se Excel

La funzione Se in Excel serve per verificare una particolare condizione da voi scelta. La funzione è infatti composta da 3 campi, nel primo viene inserita la condizione che vi interessa verificare, nel secondo campo viene inserita il valore che volete far restituire nel caso in cui la condizione sia esatta, nell’ultimo campo inserite il valore che uscirà nel caso in cui la condizione sia errata. Un esempio può essere del tipo
=SE(100-30=20, “vero”, “falso”)
il risultato sarà FALSO poichè la differenza 100-30 non restituisce 20 ma 70, infatti se la nostra formula fosse
=SE(100-30=70, “vero”, “falso”)
il risultato sarebbe VERO!
La stessa cosa si può fare inserendo, al posto della formula 100-30, anche un’operazione tra 2 o più celle per esempio
=SE(A1-A2=1, “ok”, “attenzione”)
Buon lavoro!

EXCEL: Esempi di comandi rapidi

Forse non tutti sanno che con la tastiera è possibile replicare moltissime delle operazioni che di solito siamo abituati a fare utilizzando il mouse. Purtroppo il mouse, per quanto possa essere utile, spesso ci rallenta nel lavoro perchè per compiere una sola operazione dobbiamo effettuare svariati passaggi.
Di seguito vi segnalo alcuni dei comandi rapidi più frequenti:

CATEGORIA 1:

Alt + F: aprire la finestra del Menù File

Alt + M: aprire la finestra del Menù Modifica

Alt + V: aprire la finestra del Menù Visualizza

Alt + I: aprire la finestra del Menù Inserisci

Alt + O: aprire la finestra del Menù Formato

Alt + S: aprire la finestra del Menù Strumenti

Alt + D: aprire la finestra del Menù Dati

Alt + N: aprire la finestra del Menù Finestra

CATEGORIA FILE

Ctrl + F12: aprire un documento

Ctrl + N: aprire una nuova cartella di lavoro

Maiusc + F12: salvare la cartella di lavoro

Ctrl + Maiusc + F12:stampare

CATEGORIA MODIFICA

Ctrl + Z: annullare l’ultima operazione fatta

Ctrl + C: copiare il contenuto selezionato

Ctrl + V: incollare il contenuto copiato

Ctrl + INVIO: incollare il contenuto inserito all’interno di tutte le celle selezionate

Ctrl + Maiusc + >: inserire lo stesso contenuto presente nella cella a sinistra

Ctrl + >: inserire lo stesso contenuto presente nella cella sopra

Ctrl + X: tagliare il contenuto selezionato

Ctrl + Maiusc + T: trovare(l’equivalente di Modifica-Trova)

CATEGORIA INSERISCI

Maiusc + F3: aprire la finestra per inserire una funzione

Ctrl + Maiusc + “,” (Ctrl + “;”): inserire la data attuale

Ctrl + Maiusc + “.” (Ctrl + “:”): inserire l’ora attuale

CATEGORIA FORMATO

Ctrl + L: aprire la finestra di Stile

Ctrl + B: barrare il contenuto selezionato

Ctrl + 1: entrare nella finestra relativa alla formattazione della cella

Ctrl + I: formattare in corsivo il contenuto selezionato

Ctrl + G: formattare in grassetto il contenuto selezionato

Ctrl + S: sottolineare il contenuto selezionato

CATEGORIA SEL/POS

Ctrl + W: nascondere la colonna corrente

Ctrl + Q: nascondere la riga corrente

Ctrl + TAB: passare alla cartella di lavoro successiva

F2: posizionarsi sul contenuto della cella corrente

Ctrl + Pag_SU: posizionarsi sul foglio di lavoro precedente

Ctrl + Pag_GIU: posizionarsi sul foglio di lavoro successivo

Ctrl + barra spaziatrice: selezionare la colonna corrente

Maiusc + barra spaziatrice: selezionare la riga corrente

Ctrl + Maiusc + barra spaziatrice: selezionare tutto il foglio

Maiusc + freccia cursore: selezionare un insieme di celle vicine

Il cerca.vert restituisce #N/D, come posso toglierlo?

La funzione CERCA.VERT che abbiamo visto nei primi post permette di cercare un determinato valore all’interno di una matrice e restituisce il corrispondente valore in una certa colonna (quella indicata all’interno della funzione, nel terzo argomento). Purtroppo spesso può capitare che non tutti i valori che cerchiamo siano presenti all’interno della matrice per cui la funzione, non riuscendo a trovare ciò che cerchiamo, restituisce uno scomodo #N/D.
Ebbene, per eliminare questo #N/D possiamo utilizzare una funzione che ci permetta di sostituire questo risultano con ciò che preferiamo (per esempio “nessun risultato”, “0”, “non trovato”, etc…a voi la scelta).

La funzione che dobbiamo utilizzare è la seguente:

=se(val.errore(cerca.vert(A1;$C$1:$F$100;2;falso));”record non trovato”; cerca.vert(A1;$C$1:$F$100;2;falso))

Questa funzione cerca il valore presente nella cella A1 all’interno della matrice C1:F100 e restituisce il corrispondente valore presente nella seconda colonna. Qualora non riuscisse a trovare il valore della cella A1 allora il risultato sarebbe “record non trovato”….a volte può essere meglio di un #N/D…

Come funziona il SOMMA.SE

La funzione SOMMA in excel è molto comune, permette infatti di sommare più celle selezionando un intervallo (es. =SOMMA(A1:A10), così sommiamo tutti i valori compresi tra la cella A1 e la cella A10) oppure selezionando diverse celle separate dal “;” (es =SOMMA(A1;A3;A7:A10), così sommiamo A1+A3+A7+A8+A9+A10).

La funzione SOMMA.SE permette di sommare un certo intervallo di celle sulla base di una condizione impostata dall’utente. Per intenderci, ipotizziamo di avere la seguente situazione:

A
Spesa
B
Situazione
60 Cena
75 Spesa
30 Farmacia
15 Pranzo
100 Spesa
25 Farmacia
59 Cena
34 Cena
200 Spesa

A questo punto, se volessi capire quanto ho speso tra tutte le cene, mi basterà applicare la seguente funzione:

=SOMMA.SE(B1:B10;”Cena”;A1:A10)

risultato: 153€

Se invece siamo interessati a capire quanto ci è costata la spesa scriveremo:

=SOMMA.SE(B1:B10;”Spesa”;A1:A10)

risultato: 375€

Come posso scoprire se nel contenuto di una cella c’è una formula?

Nuovo quesito del giorno: l’altro giorno al lavoro mi sono trovata di fronte ad un nuova questione, all’interno di un’elenco di dati dovevamo cercare di isolare le celle che contenevano una formula da quelle che invece contenevano un valore. Purtroppo sembra che tra le funzioni presenti in excel non ce ne sia una che permetta di identificare le celle che contengono una funzione. Per fare questa operazione abbiamo infatti bisogno di creare una funzione, che possiamo chiamare “FormulaEstrai” che ci permette di ottenere quello che cerchiamo. La funzione è la seguente:

Function FormulaEstrai(cella As Range) As String

If Left(cella.Formula, 1) = “=” Then

FormulaEstrai = cella.Formula

Else

FormulaEstrai = “nessuna formula”

End If

End Function

Questa piccola funzione ci permette di vedere se all’interno di una cella c’è una formula oppure un valore (in quest’ultimo caso la funzione restituisce “nessuna formula”).

Per esempio:

cella A1:ciao a tutti

se scriviamo

FormulaEstrai(A1)=

risultato: nessuna formula

cella A1:= lunghezza(“pippo”)

allora se scriviamo

FormulaEstrai(A1)=

risultato: =lunghezza(“pippo”)

Funzioni Excel dall’italiano all’inglese

Ultimamente hanno aggiornato al lavoro la versione di Microsoft Excel su cui lavoro, e se prima inserivo e scrivevo formule in italiano…adesso sono costretta a scriverle tutte in inglese.
Prima utilizzavo la funzione “=SOMMA”, ora devo scrivere “=SUM”. Fin qui sembra anche abbastanza semplice, ma quando devo utilizzare la funzione “=STRINGA.ESTRAI” oppure “=ANNULLA.SPAZI”, a questo punto le cose iniziano a farsi un po’ più complicate. Proprio per questo motivo ho pensato di scrivere un breve elenco delle principali funzioni che utilizzo quotidianamente riportando la descrizione sia in italiano che in inglese.

Italiano Inglese
=ANNO()……………………………………………..=YEAR()
=ANNULLA.SPAZI()…………………………..=TRIM()
=ARROTONDA()…………………………………=ROUND()
=ARROTONDA.DIFETTO()………………..=FLOOR()
=ARROTONDA.ECCESSO()………………..=CEILING()
=ARROTONDA.PER.DIF()………………….=ROUNDDOWN()
=ARROTONDA.PER.ECC()…………………=ROUNDUP()
=CERCA.VERT()…………………………………=VLOOKUP()
=CERCA.ORIZZ()……………………………….=HLOOKUP()
=CONCATENA()…………………………………=CONCATENATE()
=CONTA.NUMERI()…………………………..=COUNT()
=CONTA.SE()…………………………………….=COUNTIF()
=CONTA.VALORI()…………………………..=COUNTA()
=CONTA.VUOTE()……………………………=COUNTBLANK()
=DESTRA()………………………………………..=RIGHT()
=GIORNO()……………………………………….=DAY()
=INDICE()…………………………………………=INDEX()
=LUNGHEZZA()……………………………….=LEN()
=MAIUSC()……………………………………….=UPPER()
=MATR.SOMMA.PRODOTTO()……….=SUMPRODUCT()
=MEDIA()…………………………………………=AVERAGE()
=MESE()……………………………………………=MONTH
=NUM()…………………………………………….=N()
=O()………………………………………………….=OR()
=SE()………………………………………………..=IF()
=SINISTRA()……………………………………=LEFT()
=SOMMA()……………………………………….=SUM()
=SOMMA.SE()………………………………….=SUMIF()
=STRINGA.ESTRAI()………………………=MID()
=SUBTOTALE()……………………………….=SUBTOTAL()
=T()………………………………………………….=T()
=VAL.ERRORE()……………………………..=ISERROR()
=VALORE()……………………………………..=VALUE()

Funzione CERCA.VERT con indicatore "Vero"

Nell’esempio precedente abbiamo visto un modo per poter usare la funzione “cerca.vert” con argomento=falso. Spesso può capitare di avere una lista di numeri ai quali si vuole associare un particolare valore, una lettera oppure una percentuale. Potremmo avere una lista di valori che corrispondono alle vendite effettuate dai nostri venditori e per ciascuno di questi dobbiamo associare una percentuale di profitto che gli spetta. Ovviamente la percentuale di profitto dipende dalle vendite effettuate, maggiore sarà la vendita e maggiore sarà il guadagno. Per evitare di fare i conti a mano ci basterà creare una piccola tabella in cui segniamo le fasce di vendita con le rispettive percentuali di guadagno. Successivamente applichiamo la formula del “cerca.vert” inserendo nel quarto argomento “vero”, così facendo dovremmo ottenere la percentuale che cerchiamo.
Buona visione e buon lavoro.

Funzione CERCA.VERT con indicatore "Falso"

La funzione cerca.vert può essere utilizzata in excel quando l’utente cerca un particolare valore all’interno di una matrice. La funzione restituisce, in corrispondenza al valore cercato verticalmente nella prima colonna della matrice, un altro valore alla stessa altezza ma in una differente colonna. Questa funzione viene utilizzata se per esempio si cerca l’altezza di una persona, il colore di un articolo di abbigliamento o la spesa effettuata in un particolare mese dell’anno.
La funzione cerca.vert di excel è composta da 4 argomenti: la cella che si cerca, la matrice su cui viene effettuata la ricerca, il numero della colonna in corrispondenza della quale verrà riportato il valore, un indicatore vero/falso a seconda che si ricerchi esattamente quel valore oppure un valore vicino.
Nel video seguente potrete visualizzare un esempio pratico di utilizzo di questa funzione (il cui 4 argomento avrà come indicatore “falso”), nella matrice di sinistra sono riportati i vari mesi dell’anno con la relativa spesa sostenuta. A destra invece sono elencati 3 mesi di esempio per i quali cerchiamo la spesa effettuata.
Buona visione e buon lavoro.